MDF Compressed After Restoring database In 9.4

Problem:

Restoring a database from a .BAK file and get the following message:
” The restored MDF file is compressed and you must uncompress it for it to be used”

Or user gets error message “login failed for user” when attempting to open a database in V10.x

Cause:

At the Drive level (i.e. C:\) or folder level i.e. My Documents), there is an advanced button under the properties tab where you can command that all files contained within will be compressed. Thus if you restore your MDF into this folder it will compress it and will not be able to be used in that compressed format.

Solution:

Open Windows Explorer:
At the Drive level uncheck the Compress all Folder and Files option. Then run through the restore process again.
At the Folder level click the Advanced Button and uncheck Compress all Folders and File. Then run through the database restore process once again.